Current delays

Minor incident Webapplication
2023-12-11 13:53 CEST · 20 minutes

Updates

Resolved

The processing of invoices is now running reliably again.

December 11, 2023 · 14:13 CEST
Update

The backlog of invoices to be processed decreases.

December 11, 2023 · 14:05 CEST
Issue

Unfortunately, there are delays at the moment. The technical team is working to resolve the issue.

December 11, 2023 · 13:53 CEST

← Back