Processing issues
Minor incident
Webapplication
API
2025-03-19 18:13 CET
· 1 day, 16 hours, 37 minutes
Updates
Resolved
March 21, 2025 · 10:49 CET
The issue has been resolved and all services are up and running again.
Issue
March 19, 2025 · 18:13 CET
Due to a network outage the invoice processing did partially fail. We are currently reprocessing all failed invoices.
← Back