Uploading invoices takes longer than usual

Minor incident Webapplication API
2025-05-16 13:22 CEST · 1 day, 6 hours, 37 minutes

Updates

Issue

All systems are up an running again

May 16, 2025 · 16:00 CEST
Issue

Due to an unplanned maintainance the processing of invoices could take more time than usual.

May 16, 2025 · 13:22 CEST

← Back