Delayed processing of invoices

Minor incident Webapplication API
2025-11-03 10:15 CET · 4 hours, 49 minutes

Updates

Resolved

All systems are fully operational again.

November 3, 2025 · 15:04 CET
Investigating

We are currently experiencing an infrastructure issue causing delayed processing of uploaded invoices.
The system remains fully available, and all uploaded documents will be processed — just more slowly than usual.
Our team is working on a fix, and we expect normal processing to resume by 15:00.
We will post regular updates here and on the status page as we make progress.

November 3, 2025 · 13:15 CET

← Back