The web application isn't working

Minor incident Webapplication
2026-04-20 12:45 CEST · 1 hour, 23 minutes

Updates

Resolved

All systems are back online.

April 20, 2026 · 14:07 CEST
Issue

We were able to successfully clear the backlog of invoices. We are still working on improving performance.

April 20, 2026 · 09:03 CEST

← Back