System Performance - Recovery in Progress

Minor incident Webapplication API
2026-06-03 09:31 CEST · 7 hours, 3 minutes

Updates

Resolved

The system performance issue has been resolved

June 3, 2026 · 16:33 CEST
Issue

We are currently experiencing system-wide disruptions, due to an internal system issue.
The root cause has been resolved, and our team is actively processing the remaining backlog to fully restore normal operations as quickly as possible.

June 3, 2026 · 09:31 CEST

← Back