Delay in Email Notifications

Minor incident Webapplication
2026-06-19 11:57 CEST · 4 days, 21 hours, 18 minutes

Updates

Resolved

The email backlog has been resolved. All systems are operational as usual.

June 22, 2026 · 09:12 CEST
Issue

Due to a technical issue with our email service provider, we are currently experiencing a backlog in notification delivery. We are actively working to resolve this issue.

Thank you for your patience and understanding.

June 19, 2026 · 11:57 CEST

← Back