High Processing Volume – Potential Delays
Minor incident
Webapplication
API
2026-09-07 12:35 CEST
· 5 hours, 37 minutes
Updates
Resolved
September 7, 2026 · 18:11 CEST
Update: Normal operations resumed The backlog in invoice and batch processing has been completely resolved. All systems are operating normally without delays. Thank you for your patience.
Issue
September 7, 2026 · 08:00 CEST
We have been experiencing an exceptionally high volume of invoices and batch processing requests.
Our systems are running at maximum capacity to clear the queue as quickly as possible. All services are fully operational and running without any errors; however, processing times may be slightly longer than usual due to the heavy load.
Our engineering team is actively monitoring the situation. We appreciate your patience and understanding.
← Back